integ/security/openscap/debian/deb_folder/patches/011_remove_custom_rpath.patch

21 lines
780 B
Diff

Index: openscap/CMakeLists.txt
===================================================================
--- openscap.orig/CMakeLists.txt
+++ openscap/CMakeLists.txt
@@ -487,13 +487,13 @@ set(OSCAP_TEMP_DIR "/tmp" CACHE STRING "
# see https://cmake.org/Wiki/CMake_RPATH_handling
# use, i.e. don't skip the full RPATH for the build tree
-set(CMAKE_SKIP_BUILD_RPATH FALSE)
+set(CMAKE_SKIP_BUILD_RPATH TRUE)
# when building, don't use the install RPATH already
# (but later on when installing)
set(CMAKE_BUILD_WITH_INSTALL_RPATH FALSE)
-set(CMAKE_INSTALL_RPATH ${CMAKE_INSTALL_FULL_LIBDIR})
+#set(CMAKE_INSTALL_RPATH ${CMAKE_INSTALL_FULL_LIBDIR})
# add the automatically determined parts of the RPATH
# which point to directories outside the build tree to the install RPATH